GitHub Advisoryadvisory · Maven
GHSA-79rm-f26g-296p Jenkins Maven Release Plugin vulnerable to Cross-site Scripting
MEDIUM
Official page ↗
- Aliases
- CVE-2019-10360
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins.m2release:m2release
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-03-03
Affected packages
• Maven org.jenkins-ci.plugins.m2release:m2release: < 0.15.0 → fixed in 0.15.0
Description
A stored cross site scripting vulnerability in Jenkins Maven Release Plugin 0.14.0 and earlier allowed attackers to inject arbitrary HTML and JavaScript in the plugin-provided web pages in Jenkins.
Variables on affected views are now escaped.
Related
Alias · CVE (1)
- CVE-2019-10360 A stored cross site scripting vulnerability in Jenkins Maven Release Plugin 0.14.0 and earlier allowed attackers to inject arbitrary HTML… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness