GitHub Advisoryadvisory · PyPI

GHSA-79v4-65xg-pq4g Vulnerable OpenSSL included in cryptography wheels

LOW Published 2025-02-11 Modified 2025-02-12 Official page ↗
Aliases
CVE-2024-12797
Ecosystem
PyPI
Packages
cryptography
Severity
Low
Weaknesses
CWE-1395, CWE-392
Reviewed
2025-02-11

Affected packages

• PyPI cryptography: >= 42.0.0, < 44.0.1 → fixed in 44.0.1

Description

pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 42.0.0-44.0.0 are vulnerable to a security issue. More details about the vulnerability itself can be found in https://openssl-library.org/news/secadv/20250211.txt. If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.

Related

Alias · CVE (1)

  • CVE-2024-12797 Issue summary: Clients using RFC7250 Raw Public Keys (RPKs) to authenticate a server may fail to notice that the server was not… vulnerability

Weakness · CWE (2)

  • CWE-1395 Dependency on Vulnerable Third-Party Component weakness
  • CWE-392 Missing Report of Error Condition weakness

References