GitHub Advisoryadvisory · Packagist

GHSA-7c28-wg7r-pg6f RaspAP Command Injection vulnerability

CRITICAL Published 2023-08-01 Modified 2023-08-04 Official page ↗
Aliases
CVE-2022-39986
Ecosystem
Packagist
Packages
billz/raspap-webgui
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-77
Reviewed
2023-08-01

Affected packages

• Packagist billz/raspap-webgui: >= 2.8.0, < 2.8.8 → fixed in 2.8.8

Description

A Command injection vulnerability in RaspAP 2.8.0 thru 2.8.7 allows unauthenticated attackers to execute arbitrary commands via the `cfg_id` parameter in `/ajax/openvpn/activate_ovpncfg.php` and `/ajax/openvpn/del_ovpncfg.php`.

Related

Alias · CVE (1)

  • CVE-2022-39986 A Command injection vulnerability in RaspAP 2.8.0 thru 2.8.7 allows unauthenticated attackers to execute arbitrary commands via the cfg_id… vulnerability

Weakness · CWE (1)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness

References