GitHub Advisoryadvisory · PyPI
GHSA-7c85-87cp-mr6g LlamaIndex Vulnerable to Denial of Service (DoS)
HIGH
Official page ↗
- Aliases
- CVE-2025-1752
- Ecosystem
- PyPI
- Packages
- llama-index
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400, CWE-674
- Reviewed
- 2025-05-12
Affected packages
• PyPI llama-index: >= 0.12.15, < 0.12.21 → fixed in 0.12.21
Description
A Denial of Service (DoS) vulnerability has been identified in the KnowledgeBaseWebReader class of the run-llama/llama_index project, affecting version ~ latest(v0.12.15). The vulnerability arises due to inappropriate secure coding measures, specifically the lack of proper implementation of the max_depth parameter in the get_article_urls function. This allows an attacker to exhaust Python's recursion limit through repeated function calls, leading to resource consumption and ultimately crashing the Python process.
Related
Alias · CVE (1)
- CVE-2025-1752 A Denial of Service (DoS) vulnerability has been identified in the KnowledgeBaseWebReader class of the run-llama/llama_index project,… vulnerability