GitHub Advisoryadvisory · Packagist

GHSA-7ff4-cv53-4cjq phpMyAdmin SQL injection vulnerability

CRITICAL Published 2022-05-24 Modified 2024-04-24 Official page ↗
Aliases
CVE-2020-26935
Ecosystem
Packagist
Packages
phpmyadmin/phpmyadmin
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-89
Reviewed
2024-04-24

Affected packages

• Packagist phpmyadmin/phpmyadmin: >= 4.9.0, < 4.9.6 → fixed in 4.9.6 • Packagist phpmyadmin/phpmyadmin: >= 5.0.0, < 5.0.3 → fixed in 5.0.3

Description

An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before 5.0.3. A SQL injection vulnerability was discovered in how phpMyAdmin processes SQL statements in the search feature. An attacker could use this flaw to inject malicious SQL in to a query.

Related

Alias · CVE (1)

  • CVE-2020-26935 An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before 5.0.3. vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References