GitHub Advisoryadvisory · Packagist
GHSA-7ffh-cjvg-fpr4 Drupal Settings Tray access bypass
MEDIUM
Official page ↗
- Aliases
- CVE-2017-6931
- Ecosystem
- Packagist
- Packages
- drupal/core, drupal/drupal
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-434
- Reviewed
- 2024-04-23
Affected packages
• Packagist drupal/core: >= 8.4.0, < 8.4.5 → fixed in 8.4.5
• Packagist drupal/drupal: >= 8.4.0, < 8.4.5 → fixed in 8.4.5
Description
In Drupal versions 8.4.x versions before 8.4.5 the Settings Tray module has a vulnerability that allows users to update certain data that they do not have the permissions for. If you have implemented a Settings Tray form in contrib or a custom module, the correct access checks should be added. This release fixes the only two implementations in core, but does not harden against other such bypasses. This vulnerability can be mitigated by disabling the Settings Tray module.
Related
Alias · CVE (1)
- CVE-2017-6931 In Drupal versions 8.4.x versions before 8.4.5 the Settings Tray module has a vulnerability that allows users to update certain data that… vulnerability
Weakness · CWE (1)
- CWE-434 Unrestricted Upload of File with Dangerous Type weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-6931 advisory
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2017-6931.yaml web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2017-6931.yaml web
- https://github.com/drupal/core package
- https://www.drupal.org/sa-core-2018-001 web