GitHub Advisoryadvisory · Packagist

GHSA-7fh9-933g-885p Drupal Core Remote Code Execution Vulnerability

CRITICAL Published 2022-05-14 Modified 2025-10-22 Official page ↗
Aliases
CVE-2018-7600
Ecosystem
Packagist
Packages
drupal/core, drupal/drupal
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H
Weaknesses
CWE-20
Reviewed
2024-04-23

Affected packages

• Packagist drupal/core: >= 7.0, < 7.58 → fixed in 7.58 • Packagist drupal/core: >= 8.0, < 8.3.9 → fixed in 8.3.9 • Packagist drupal/core: >= 8.4.0, < 8.4.6 → fixed in 8.4.6 • Packagist drupal/core: >= 8.5.0, < 8.5.1 → fixed in 8.5.1 • Packagist drupal/drupal: >= 7.0, < 7.58 → fixed in 7.58 • Packagist drupal/drupal: >= 8.0, < 8.3.9 → fixed in 8.3.9 • Packagist drupal/drupal: >= 8.4, < 8.4.6 → fixed in 8.4.6 • Packagist drupal/drupal: >= 8.5, < 8.5.1 → fixed in 8.5.1

Description

Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1 allows remote attackers to execute arbitrary code because of an issue affecting multiple subsystems with default or common module configurations.

Related

Alias · CVE (1)

  • CVE-2018-7600 Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1 allows remote attackers to execute arbitrary code because… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References