GitHub Advisoryadvisory · PyPI

GHSA-7fqm-jm52-f9vc rdiffweb vulnerable to Use of Cache Containing Sensitive Information

MEDIUM Published 2022-09-29 Modified 2024-10-16 Official page ↗
Aliases
CVE-2022-3292
Ecosystem
PyPI
Packages
rdiffweb
Severity
Moderate
CVSS vector
CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-524
Reviewed
2022-09-30

Affected packages

• PyPI rdiffweb: < 2.4.9 → fixed in 2.4.9

Description

rdiffweb prior to version 2.4.9 is vulnerable to Use of Cache Containing Sensitive Information. Due to improper cache control, an attacker can view sensitive information even if they are not logged into an account. Version 2.4.9 contains a patch for this issue.

Related

Alias · CVE (1)

  • CVE-2022-3292 Use of Cache Containing Sensitive Information in GitHub repository ikus060/rdiffweb prior to 2.4.8. vulnerability

Weakness · CWE (1)

  • CWE-524 Use of Cache Containing Sensitive Information weakness

References