GitHub Advisoryadvisory · Go
GHSA-7g2v-2frm-rg94 Mattermost Incorrect Authorization vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2023-2515
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server/v6
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-863
- Reviewed
- 2023-05-12
Affected packages
• Go github.com/mattermost/mattermost-server/v6: < 7.1.8 → fixed in 7.1.8
• Go github.com/mattermost/mattermost-server/v6: >= 7.2.0, < 7.7.4 → fixed in 7.7.4
• Go github.com/mattermost/mattermost-server/v6: >= 7.8.0, < 7.8.3 → fixed in 7.8.3
• Go github.com/mattermost/mattermost-server/v6: >= 7.9.0, < 7.9.2 → fixed in 7.9.2
Description
Mattermost fails to restrict a user with permissions to edit other users and to create personal access tokens from elevating their privileges to system admin
Related
Alias · CVE (1)
- CVE-2023-2515 Mattermost fails to restrict a user with permissions to edit other users and to create personal access tokens from elevating their… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness