GitHub Advisoryadvisory · crates.io
GHSA-7gf7-jv65-wjmh xml-rs vulnerable to denial of service via invalid token in XML document
HIGH
Official page ↗
- Aliases
- CVE-2023-34411
- Ecosystem
- crates.io
- Packages
- xml-rs
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-611, CWE-617
- Reviewed
- 2023-06-06
Affected packages
• crates.io xml-rs: >= 0.8.9, < 0.8.14 → fixed in 0.8.14
Description
The xml-rs crate >= 0.8.9 and < 0.8.14 for Rust and Crab allows a denial of service (panic) via an invalid <! token (such as <!DOCTYPEs/%<!A nesting) in an XML document.
Related
Alias · CVE (1)
- CVE-2023-34411 The xml-rs crate before 0.8.14 for Rust and Crab allows a denial of service (panic) via an invalid <! vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-34411 advisory
- https://github.com/netvl/xml-rs/pull/226 web
- https://github.com/00xc/xml-rs/commit/0f084d45aa53e4a27476961785f59f2bd7d59a9f web
- https://github.com/netvl/xml-rs/commit/014d808be900c85a0afc5ccdfe668be040d175aa web
- https://github.com/netvl/xml-rs/commit/c09549a187e62d39d40467f129e64abf32efc35c web
- https://github.com/netvl/xml-rs package
- https://github.com/netvl/xml-rs/compare/0.8.13...0.8.14 web