GitHub Advisoryadvisory · PyPI
GHSA-7gfq-f96f-g85j langchain vulnerable to arbitrary code execution
CRITICAL
Official page ↗
- Aliases
- CVE-2023-36281
- Ecosystem
- PyPI
- Packages
- langchain
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2023-08-23
Affected packages
• PyPI langchain: < 0.0.312 → fixed in 0.0.312
Description
An issue in langchain v.0.0.171 allows a remote attacker to execute arbitrary code via the via the a json file to the `load_prompt` parameter. This is related to `__subclasses__` or a template.
Related
Alias · CVE (1)
- CVE-2023-36281 An issue in langchain v.0.0.171 allows a remote attacker to execute arbitrary code via a JSON file to load_prompt. vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-36281 advisory
- https://github.com/hwchase17/langchain/issues/4394 web
- https://github.com/langchain-ai/langchain/pull/10252 web
- https://github.com/langchain-ai/langchain/commit/22abeb9f6cc555591bf8e92b5e328e43aa07ff6c web
- https://aisec.today/LangChain-2e6244a313dd46139c5ef28cbcab9e55 web
- https://github.com/langchain-ai/langchain package
- https://github.com/langchain-ai/langchain/releases/tag/v0.0.312 web
- https://github.com/pypa/advisory-database/tree/main/vulns/langchain/PYSEC-2023-151.yaml web