GitHub Advisoryadvisory · npm

GHSA-7gmr-mq3h-m5h9 Denial of Service Vulnerability in React Server Components

HIGH Published 2025-12-12 Modified 2025-12-12 Official page ↗
Aliases
CVE-2025-67779
Ecosystem
npm
Packages
react-server-dom-parcel, react-server-dom-turbopack, react-server-dom-webpack
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400, CWE-502
Reviewed
2025-12-12

Affected packages

• npm react-server-dom-parcel: >= 19.0.2, < 19.0.3 → fixed in 19.0.3 • npm react-server-dom-parcel: >= 19.1.3, < 19.1.4 → fixed in 19.1.4 • npm react-server-dom-parcel: >= 19.2.2, < 19.2.3 → fixed in 19.2.3 • npm react-server-dom-turbopack: >= 19.0.2, < 19.0.3 → fixed in 19.0.3 • npm react-server-dom-turbopack: >= 19.1.3, < 19.1.4 → fixed in 19.1.4 • npm react-server-dom-turbopack: >= 19.2.2, < 19.2.3 → fixed in 19.2.3 • npm react-server-dom-webpack: >= 19.0.2, < 19.0.3 → fixed in 19.0.3 • npm react-server-dom-webpack: >= 19.1.3, < 19.1.4 → fixed in 19.1.4 • npm react-server-dom-webpack: >= 19.2.2, < 19.2.3 → fixed in 19.2.3

Description

Impact It was found that the fix to address CVE-2025-55184 in React Server Components was incomplete and does not prevent a denial of service attack in a specific case. We recommend updating immediately. The vulnerability exists in versions 19.0.2, 19.1.3, and 19.2.2 of: • react-server-dom-webpack • react-server-dom-parcel • react-server-dom-turbopack These issues are present in the patches published on December 11th, 2025. Patches Fixes were back ported to versions 19.0.3, 19.1.4, and 19.2.3. If you are using any of the above packages please upgrade to any of the fixed versions immediately. If your app’s React code does not use a server, your app is not affected by this vulnerability. If your app does not use a framework, bundler, or bundler plugin that supports React Server Components, your app is not affected by this vulnerability. References See the blog post for more information and upgrade instructions.

Related

Alias · CVE (1)

  • CVE-2025-67779 It was found that the fix addressing CVE-2025-55184 in React Server Components was incomplete and does not prevent a denial of service… vulnerability

Weakness · CWE (2)

  • CWE-400 Uncontrolled Resource Consumption weakness
  • CWE-502 Deserialization of Untrusted Data weakness

References