GitHub Advisoryadvisory · Packagist

GHSA-7h8v-2v8x-h264 SQL Injection in moodle

MEDIUM Published 2021-03-29 Modified 2021-03-24 Official page ↗
Aliases
CVE-2020-25700
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-89
Reviewed
2021-03-24

Affected packages

• Packagist moodle/moodle: >= 3.9.0, < 3.9.3 → fixed in 3.9.3 • Packagist moodle/moodle: >= 3.8.0, < 3.8.6 → fixed in 3.8.6 • Packagist moodle/moodle: >= 3.7.0, < 3.7.9 → fixed in 3.7.9 • Packagist moodle/moodle: >= 3.5.0, < 3.5.15 → fixed in 3.5.15

Description

In moodle, some database module web services allowed students to add entries within groups they did not belong to. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.8.6, 3.7.9, 3.5.15, and 3.10.

Related

Alias · CVE (1)

  • CVE-2020-25700 In moodle, some database module web services allowed students to add entries within groups they did not belong to. vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References