GitHub Advisoryadvisory · Packagist

GHSA-7hh9-gp72-wh7h Auth0 Laravel SDK has Improper Audience Validation via Auth0-PHP SDK dependency

MEDIUM Published 2025-12-17 Modified 2025-12-17 Official page ↗
Ecosystem
Packagist
Packages
auth0/login
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-1395, CWE-863
Reviewed
2025-12-17

Affected packages

• Packagist auth0/login: >= 7.0.0, < 7.20.0 → fixed in 7.20.0

Description

Description In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens. Affected product and versions Users are affected if they meet the following preconditions: • Applications using the Auth0 laravel-auth0 SDK with versions between 7.0.0 and 7.19.0, • Auth0 laravel-auth0 SDK uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0. Resolution Upgrade Auth0/laravel-auth0 to version 7.20.0 or greater. Acknowledgement Okta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.

Related

Weakness · CWE (2)

  • CWE-1395 Dependency on Vulnerable Third-Party Component weakness
  • CWE-863 Incorrect Authorization weakness

References