GitHub Advisoryadvisory · RubyGems
GHSA-7hp2-xwpj-95jq Denial of service or RCE from libxml2 and libxslt
HIGH
Official page ↗
- Aliases
- CVE-2015-8806
- Ecosystem
- RubyGems
- Packages
- nokogiri
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-125
- Reviewed
- 2020-06-16
Affected packages
• RubyGems nokogiri: >= 1.6.0, < 1.6.8 → fixed in 1.6.8
Description
Nokogiri is affected by series of vulnerabilities in libxml2 and libxslt, which are libraries Nokogiri depends on. It was discovered that libxml2 and libxslt incorrectly handled certain malformed documents, which can allow malicious users to cause issues ranging from denial of service to remote code execution attacks.
Related
Alias · CVE (1)
- CVE-2015-8806 dict.c in libxml2 allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via an… vulnerability
Weakness · CWE (1)
- CWE-125 Out-of-bounds Read weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-8806 advisory
- https://github.com/sparklemotion/nokogiri/issues/1473 web
- https://bugzilla.gnome.org/show_bug.cgi?id=749115 web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/CVE-2015-8806.yml web
- https://github.com/sparklemotion/nokogiri package
- https://security.gentoo.org/glsa/201701-37 web
- https://web.archive.org/web/20160928171015/http://www.securityfocus.com/bid/82071 web
- https://www.debian.org/security/2016/dsa-3593 web
- http://www.openwall.com/lists/oss-security/2016/02/03/5 web
- http://www.oracle.com/technetwork/topics/security/bulletinjul2016-3090568.html web
- http://www.ubuntu.com/usn/USN-2994-1 web