GitHub Advisoryadvisory · Packagist
GHSA-7hrj-3c9x-xv5h Magento has incorrect authorization issue that leads to arbitrary file system read
HIGH
Official page ↗
- Aliases
- CVE-2025-49556
- Ecosystem
- Packagist
- Packages
- magento/project-community-edition, magento/community-edition
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2025-10-21
Affected packages
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
• Packagist magento/community-edition: >= 2.4.9-alpha1, < 2.4.9-alpha2 → fixed in 2.4.9-alpha2
• Packagist magento/community-edition: >= 2.4.8-beta1, < 2.4.8-p2 → fixed in 2.4.8-p2
• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-p7 → fixed in 2.4.7-p7
• Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p12 → fixed in 2.4.6-p12
• Packagist magento/community-edition: < 2.4.5-p14 → fixed in 2.4.5-p14
• Packagist magento/community-edition: 2.4.5 (no fix yet)
• Packagist magento/community-edition: 2.4.6 (no fix yet)
• Packagist magento/community-edition: 2.4.7 (no fix yet)
• Packagist magento/community-edition: 2.4.8 (no fix yet)
Description
Magento versions 2.4.9-alpha1, 2.4.8-p1, 2.4.7-p6, 2.4.6-p11, 2.4.5-p13, 2.4.4-p14 and earlier are affected by an Incorrect Authorization vulnerability that could result in a security feature bypass. An attacker could leverage this vulnerability to bypass security measures and gain unauthorized read access. Exploitation of this issue does not require user interaction, and scope is unchanged.
Related
Alias · CVE (1)
- CVE-2025-49556 Adobe Commerce versions 2.4.9-alpha1, 2.4.8-p1, 2.4.7-p6, 2.4.6-p11, 2.4.5-p13, 2.4.4-p14 and earlier are affected by an Incorrect… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness