GitHub Advisoryadvisory · PyPI

GHSA-7j7m-v7m3-jqm7 Scrapy decompression bomb vulnerability

HIGH Published 2024-02-16 Modified 2024-04-16 Official page ↗
Aliases
CVE-2024-3572
Ecosystem
PyPI
Packages
scrapy
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-409
Reviewed
2024-02-16

Affected packages

• PyPI scrapy: >= 2.0.0, < 2.11.1 → fixed in 2.11.1 • PyPI scrapy: < 1.8.4 → fixed in 1.8.4

Description

Impact Scrapy limits allowed response sizes by default through the `DOWNLOAD_MAXSIZE` and `DOWNLOAD_WARNSIZE` settings. However, those limits were only being enforced during the download of the raw, usually-compressed response bodies, and not during decompression, making Scrapy vulnerable to decompression bombs. A malicious website being scraped could send a small response that, on decompression, could exhaust the memory available to the Scrapy process, potentially affecting any other process sharing that memory, and affecting disk usage in case of uncompressed response caching. Patches Upgrade to Scrapy 2.11.1. If you are using Scrapy 1.8 or a lower version, and upgrading to Scrapy 2.11.1 is not an option, you may upgrade to Scrapy 1.8.4 instead. Workarounds There is no easy workaround. Disabling HTTP decompression altogether is impractical, as HTTP compression is a rather common practice. However, it is technically possible to manually backport the 2.11.1 or 1.8.4 fix, replacing the corresponding components of an unpatched version of Scrapy with patched versions copied into your own code. Acknowledgements This security issue was reported by @dmandefy through huntr.com.

Related

Alias · CVE (1)

  • CVE-2024-3572 The scrapy/scrapy project is vulnerable to XML External Entity (XXE) attacks due to the use of lxml.etree.fromstring for parsing untrusted… vulnerability

Weakness · CWE (1)

  • CWE-409 Improper Handling of Highly Compressed Data (Data Amplification) weakness

References