GitHub Advisoryadvisory · Packagist

GHSA-7j98-h7fp-4vwj smarty Cross-site Scripting vulnerability in Javascript escaping

HIGH Published 2023-03-29 Modified 2025-11-04 Official page ↗
Aliases
CVE-2023-28447
Ecosystem
Packagist
Packages
smarty/smarty
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
Weaknesses
CWE-79
Reviewed
2023-03-29

Affected packages

• Packagist smarty/smarty: >= 4.0.0, < 4.3.1 → fixed in 4.3.1 • Packagist smarty/smarty: < 3.1.48 → fixed in 3.1.48

Description

Impact An attacker could exploit this vulnerability to execute arbitrary JavaScript code in the context of the user's browser session. This may lead to unauthorized access to sensitive user data, manipulation of the web application's behavior, or unauthorized actions performed on behalf of the user. Patches Please upgrade to the most recent version of Smarty v3 or v4. For more information If you have any questions or comments about this advisory please open an issue in the Smarty repo

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References