GitHub Advisoryadvisory · Maven
GHSA-7jh8-ghwc-82cw Cross-site Scripting (XSS) vulnerability in Jenkins Continuous Integration with Toad Edge Plugin
HIGH
Official page ↗
- Aliases
- CVE-2022-28145
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:ci-with-toad-edge
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2022-11-29
Affected packages
• Maven org.jenkins-ci.plugins:ci-with-toad-edge: < 2.4 → fixed in 2.4
Description
Jenkins Continuous Integration with Toad Edge Plugin 2.3 and earlier does not apply Content-Security-Policy headers to report files it serves, resulting in a stored cross-site scripting (XSS) exploitable by attackers with Item/Configure permission or otherwise able to control report contents.
Related
Alias · CVE (1)
- CVE-2022-28145 Jenkins Continuous Integration with Toad Edge Plugin 2.3 and earlier does not apply Content-Security-Policy headers to report files it… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-28145 advisory
- https://github.com/jenkinsci/ci-with-toad-edge-plugin/commit/d6b2292949d0cddf4a2981fefbf3e30d1dfcd88a web
- https://github.com/jenkinsci/ci-with-toad-edge-plugin package
- https://www.jenkins.io/security/advisory/2022-03-29/#SECURITY-1892 web
- http://www.openwall.com/lists/oss-security/2022/03/29/1 web