GitHub Advisoryadvisory · Packagist
GHSA-7jr4-hgqx-vwgq Access bypass in Drupal core
MEDIUM
Official page ↗
- Aliases
- CVE-2022-25274
- Ecosystem
- Packagist
- Packages
- drupal/core
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2023-04-26
Affected packages
• Packagist drupal/core: >= 9.3.0, < 9.3.12 → fixed in 9.3.12
Description
Drupal 9.3 implemented a generic entity access API for entity revisions. However, this API was not completely integrated with existing permissions, resulting in some possible access bypass for users who have access to use revisions of content generally, but who do not have access to individual items of node and media content. This vulnerability only affects sites using Drupal's revision system.
All releases prior to Drupal 9.3 (including Drupal 7) are not affected.
Related
Alias · CVE (1)
- CVE-2022-25274 Drupal 9.3 implemented a generic entity access API for entity revisions. vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness