GitHub Advisoryadvisory · npm

GHSA-7jxr-cg7f-gpgv vm2 vulnerable to sandbox escape

CRITICAL Published 2023-04-07 Modified 2023-04-07 Official page ↗
Aliases
CVE-2023-29017
Ecosystem
npm
Packages
vm2
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-913
Reviewed
2023-04-07

Affected packages

• npm vm2: < 3.9.15 → fixed in 3.9.15

Description

vm2 was not properly handling host objects passed to `Error.prepareStackTrace` in case of unhandled async errors. • vm2 version: ~3.9.14 • Node version: 18.15.0, 19.8.1, 17.9.1 Impact A threat actor can bypass the sandbox protections to gain remote code execution rights on the host running the sandbox. Patches This vulnerability was patched in the release of version `3.9.15` of `vm2`. Workarounds None.

Related

Alias · CVE (1)

  • CVE-2023-29017 vm2 is a sandbox that can run untrusted code with whitelisted Node's built-in modules. vulnerability

Weakness · CWE (1)

  • CWE-913 Improper Control of Dynamically-Managed Code Resources weakness

References