GitHub Advisoryadvisory · Packagist

GHSA-7m9h-v68w-pfw3 Neos CMS vulnerable to XSS in various backend modules

MEDIUM Published 2022-06-03 Modified 2022-08-30 Official page ↗
Aliases
CVE-2022-30429
Ecosystem
Packagist
Packages
neos/neos
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2022-08-30

Affected packages

• Packagist neos/neos: >= 3.3.0, < 4.4.0 → fixed in 4.4.0 • Packagist neos/neos: >= 5.3.0, < 5.3.10 → fixed in 5.3.10 • Packagist neos/neos: >= 7.0.0, < 7.0.9 → fixed in 7.0.9 • Packagist neos/neos: >= 7.1.0, < 7.1.7 → fixed in 7.1.7 • Packagist neos/neos: >= 7.2.0, < 7.2.6 → fixed in 7.2.6 • Packagist neos/neos: >= 7.3.0, < 7.3.4 → fixed in 7.3.4 • Packagist neos/neos: >= 8.0.0, < 8.0.2 → fixed in 8.0.2

Description

Multiple cross-site scripting (XSS) vulnerabilities in Neos CMS allow attackers with the editor role or higher to inject arbitrary script or HTML code using the editor function, the deletion of assets, or a workspace title. The vulnerabilities were found in versions 3.3.29 and 8.0.1 and could also be present in all intermediate versions.

Related

Alias · CVE (1)

  • CVE-2022-30429 Multiple cross-site scripting (XSS) vulnerabilities in Neos CMS allow attackers with the editor role or higher to inject arbitrary script… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References