GitHub Advisoryadvisory · Maven

GHSA-7mg2-6c6v-342r Apache Pulsar: Improper Authorization For Namespace and Topic Management Endpoints

MEDIUM Published 2024-04-02 Modified 2024-05-02 Official page ↗
Aliases
CVE-2024-29834
Ecosystem
Maven
Packages
org.apache.pulsar:pulsar-broker
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weaknesses
CWE-863
Reviewed
2024-04-03

Affected packages

• Maven org.apache.pulsar:pulsar-broker: >= 2.7.1, <= 2.10.6 (no fix yet) • Maven org.apache.pulsar:pulsar-broker: >= 2.11.0, <= 2.11.4 (no fix yet) • Maven org.apache.pulsar:pulsar-broker: >= 3.0.0, < 3.0.4 → fixed in 3.0.4 • Maven org.apache.pulsar:pulsar-broker: >= 3.1.0, <= 3.1.3 (no fix yet) • Maven org.apache.pulsar:pulsar-broker: >= 3.2.0, < 3.2.2 → fixed in 3.2.2

Description

This vulnerability allows authenticated users with produce or consume permissions to perform unauthorized operations on partitioned topics, such as unloading topics and triggering compaction. These management operations should be restricted to users with the tenant admin role or superuser role. An authenticated user with produce permission can create subscriptions and update subscription properties on partitioned topics, even though this should be limited to users with consume permissions. This impact analysis assumes that Pulsar has been configured with the default authorization provider. For custom authorization providers, the impact could be slightly different. Additionally, the vulnerability allows an authenticated user to read, create, modify, and delete namespace properties in any namespace in any tenant. In Pulsar, namespace properties are reserved for user provided metadata about the namespace. This issue affects Apache Pulsar versions from 2.7.1 to 2.10.6, from 2.11.0 to 2.11.4, from 3.0.0 to 3.0.3, from 3.1.0 to 3.1.3, and from 3.2.0 to 3.2.1. 3.0 Apache Pulsar users should upgrade to at least 3.0.4. 3.1 and 3.2 Apache Pulsar users should upgrade to at least 3.2.2. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Related

Alias · CVE (1)

  • CVE-2024-29834 This vulnerability allows authenticated users with produce or consume permissions to perform unauthorized operations on partitioned topics,… vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References