GitHub Advisoryadvisory · Maven

GHSA-7mqj-xgf8-p59v Apache NiFi Cross-site Scripting vulnerability

MEDIUM Published 2024-10-29 Modified 2024-10-29 Official page ↗
Aliases
CVE-2024-45477
Ecosystem
Maven
Packages
org.apache.nifi:nifi-web-ui
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-10-29

Affected packages

• Maven org.apache.nifi:nifi-web-ui: >= 1.10.0, < 1.28.0 → fixed in 1.28.0 • Maven org.apache.nifi:nifi-web-ui: >= 2.0.0-M1, < 2.0.0-M4 → fixed in 2.0.0-M4

Description

Apache NiFi 1.10.0 through 1.27.0 and 2.0.0-M1 through 2.0.0-M3 support a description field for Parameters in a Parameter Context configuration that is vulnerable to cross-site scripting. An authenticated user, authorized to configure a Parameter Context, can enter arbitrary JavaScript code, which the client browser will execute within the session context of the authenticated user. Upgrading to Apache NiFi 1.28.0 or 2.0.0-M4 is the recommended mitigation.

Related

Alias · CVE (1)

  • CVE-2024-45477 Apache NiFi 1.10.0 through 1.27.0 and 2.0.0-M1 through 2.0.0-M3 support a description field for Parameters in a Parameter Context… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References