GitHub Advisoryadvisory · RubyGems, npm, Maven, Packagist, NuGet

GHSA-7mvr-5x2g-wfc8 Bootstrap Cross-site Scripting vulnerability

MEDIUM Published 2018-09-13 Modified 2026-06-08 Official page ↗
Aliases
CVE-2018-14042
Ecosystem
RubyGems, npm, Maven, Packagist, NuGet
Packages
bootstrap, org.webjars:bootstrap, twbs/bootstrap, bootstrap-sass, bootstrap.sass
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• RubyGems bootstrap: >= 4.0.0, < 4.1.2 → fixed in 4.1.2 • RubyGems bootstrap: >= 2.3.0, < 3.4.0 → fixed in 3.4.0 • npm bootstrap: >= 4.0.0, < 4.1.2 → fixed in 4.1.2 • npm bootstrap: >= 2.3.0, < 3.4.0 → fixed in 3.4.0 • Maven org.webjars:bootstrap: >= 4.0.0, < 4.1.2 → fixed in 4.1.2 • Maven org.webjars:bootstrap: >= 2.3.0, < 3.4.0 → fixed in 3.4.0 • Packagist twbs/bootstrap: >= 4.0.0, < 4.1.2 → fixed in 4.1.2 • Packagist twbs/bootstrap: >= 2.3.0, < 3.4.0 → fixed in 3.4.0 • NuGet bootstrap: >= 4.0.0, < 4.1.2 → fixed in 4.1.2 • NuGet bootstrap: >= 2.3.0, < 3.4.0 → fixed in 3.4.0 • RubyGems bootstrap-sass: >= 2.3.0, < 3.4.0 → fixed in 3.4.0 • npm bootstrap-sass: >= 2.0.4, < 3.4.0 → fixed in 3.4.0 • NuGet bootstrap.sass: >= 4.0.0, < 4.1.2 → fixed in 4.1.2

Description

In Bootstrap starting in version 2.3.0 and prior to versions 3.4.0 and 4.1.2, XSS is possible in the data-container property of tooltip. This is similar to CVE-2018-14041.

Related

Alias · CVE (1)

  • CVE-2018-14042 In Bootstrap before 4.1.2, XSS is possible in the data-container property of tooltip. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References