GitHub Advisoryadvisory · Maven

GHSA-7phw-cxx7-q9vq Spring Framework is vulnerable to security bypass via mvcRequestMatcher pattern mismatch

CRITICAL Published 2023-03-28 Modified 2025-09-23 Official page ↗
Aliases
CVE-2023-20860
Ecosystem
Maven
Packages
org.springframework:spring, org.springframework:spring-webmvc
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Reviewed
2023-03-28

Affected packages

• Maven org.springframework:spring: >= 6.0.0, < 6.0.7 → fixed in 6.0.7 • Maven org.springframework:spring: >= 5.3.0, < 5.3.26 → fixed in 5.3.26 • Maven org.springframework:spring-webmvc: >= 6.0.0, < 6.0.7 → fixed in 6.0.7 • Maven org.springframework:spring-webmvc: >= 5.3.0, < 5.3.26 → fixed in 5.3.26

Description

Spring Framework running version 6.0.0 - 6.0.6 or 5.3.0 - 5.3.25 using "**" as a pattern in Spring Security configuration with the mvcRequestMatcher creates a mismatch in pattern matching between Spring Security and Spring MVC, and the potential for a security bypass.

Related

Alias · CVE (1)

  • CVE-2023-20860 Spring Framework running version 6.0.0 - 6.0.6 or 5.3.0 - 5.3.25 using "**" as a pattern in Spring Security configuration with the… vulnerability

References