GitHub Advisoryadvisory · PyPI
GHSA-7pq6-v88g-wf3w Sentry's improper authentication on SAML SSO process allows user impersonation
CRITICAL
Official page ↗
- Aliases
- CVE-2025-22146
- Ecosystem
- PyPI
- Packages
- sentry
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-287
- Reviewed
- 2025-01-15
Affected packages
• PyPI sentry: >= 21.12.0, < 25.1.0 → fixed in 25.1.0
Description
Impact
A critical vulnerability was discovered in the SAML SSO implementation of Sentry. It was reported to us via our private bug bounty program.
The vulnerability allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. The victim email address must be known in order to exploit this vulnerability.
Patches
• Sentry SaaS: The fix was deployed on Jan 14, 2025.
• Self-Hosted Sentry: If only a single organization is allowed (`SENTRY_SINGLE_ORGANIZATION = True`), then no action is needed. Otherwise, users should upgrade to version 25.1.0 or higher.
Workarounds
No known workarounds.
References
• https://github.com/getsentry/sentry/pull/83407
Related
Alias · CVE (1)
- CVE-2025-22146 Sentry is a developer-first error tracking and performance monitoring tool. vulnerability
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness
References
- https://github.com/getsentry/sentry/security/advisories/GHSA-7pq6-v88g-wf3w web
- https://nvd.nist.gov/vuln/detail/CVE-2025-22146 advisory
- https://github.com/getsentry/sentry/pull/83407 web
- https://github.com/getsentry/sentry/commit/6db508f7949d117c7dff748a3c82c3a272bf7cfd web
- https://github.com/getsentry/sentry package