GitHub Advisoryadvisory · npm
GHSA-7px7-7xjx-hxm8 Marked vulnerable to XSS from data URIs
MEDIUM
Official page ↗
- Aliases
- CVE-2017-1000427
- Ecosystem
- npm
- Packages
- marked
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2020-06-16
Affected packages
• npm marked: < 0.3.7 → fixed in 0.3.7
Description
marked version 0.3.6 and earlier is vulnerable to an XSS attack in the data: URI parser.
Related
Alias · CVE (1)
- CVE-2017-1000427 marked version 0.3.6 and earlier is vulnerable to an XSS attack in the data: URI parser. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-1000427 advisory
- https://github.com/advisories/GHSA-7px7-7xjx-hxm8 advisory
- https://github.com/markedjs/marked package
- https://lists.fedoraproject.org/archives/list/[email protected]/message/BO2RMVVZVV6NFTU46B5RYRK7ZCXYARZS web
- https://lists.fedoraproject.org/archives/list/[email protected]/message/M6BJG6RGDH7ZWVVAUFBFI5L32RSMQN2S web
- https://snyk.io/vuln/npm:marked:20170112 web