GitHub Advisoryadvisory · Packagist
GHSA-7q44-r25x-wm4q Remote Code Execution vulnerability in PHPMailer 6.4.1 running on Windows
HIGH
Official page ↗
- Aliases
- CVE-2021-34551
- Ecosystem
- Packagist
- Packages
- phpmailer/phpmailer
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-434, CWE-94
- Reviewed
- 2021-06-16
Affected packages
• Packagist phpmailer/phpmailer: < 6.5.0 → fixed in 6.5.0
Description
PHPMailer 6.4.1 contains a possible remote code execution vulnerability through the `$lang_path` parameter of the `setLanguage()` method. If the `$lang_path` parameter is passed unfiltered from user input, it can be set to a UNC path, and if an attacker is also able to create a remote mount on the server that the UNC path points to, a script file under their control may be executed.
Impact
Arbitrary code may be run by a remote attacker under the web server or PHP process running on Window hosts.
Patches
Mitigated in PHPMailer 6.5.0 by no longer treating translation files as PHP code, but by parsing their text content directly.
This approach avoids the possibility of executing unknown code while retaining backward compatibility. This isn't ideal, so the current translation format is deprecated and will be replaced in the next major release.
Workarounds
Any of:
• Ensure that calling code does not pass unfiltered user-supplied data to the `$lang_path` parameter of the `setLanguage()` method.
• Block or filter the use of unknown UNC paths in this parameter (or altogether).
• Ensure that unauthorised users do not have the ability to read from unknown remote servers via UNC paths.
• Run on an OS that does not support UNC paths
References
CVE-2021-34551.
Reported by listensec.com via Tidelift.
For more information
If you have any questions or comments about this advisory:
• Open an issue in PHPMailer
• Email the maintainers
Related
Alias · CVE (1)
- CVE-2021-34551 PHPMailer before 6.5.0 on Windows allows remote code execution if lang_path is untrusted data and has a UNC pathname. vulnerability
References
- https://github.com/PHPMailer/PHPMailer/security/advisories/GHSA-7q44-r25x-wm4q web
- https://nvd.nist.gov/vuln/detail/CVE-2021-34551 advisory
- https://github.com/PHPMailer/PHPMailer/commit/acd264bf17ff4ac5c915f0d4226dce8a9ea70bc3 web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/phpmailer/phpmailer/CVE-2021-34551.yaml web
- https://github.com/PHPMailer/PHPMailer/blob/master/SECURITY.md web
- https://github.com/PHPMailer/PHPMailer/releases/tag/v6.5.0 web
- https://lists.fedoraproject.org/archives/list/[email protected]/message/3YRMWGA4VTMXFB22KICMB7YMFZNFV3EJ web
- https://lists.fedoraproject.org/archives/list/[email protected]/message/FJYSOFCUBS67J3TKR74SD3C454N7VTYM web