GitHub Advisoryadvisory · Maven

GHSA-7qw5-pqhc-xm4g Users with SCRIPT right can execute arbitrary code in XWiki

LOW Published 2020-09-10 Modified 2021-11-19 Official page ↗
Aliases
CVE-2020-15171
Ecosystem
Maven
Packages
org.xwiki.platform:xwiki-platform-oldcore
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-74, CWE-94
Reviewed
2020-09-10

Affected packages

• Maven org.xwiki.platform:xwiki-platform-oldcore: < 11.10.5 → fixed in 11.10.5 • Maven org.xwiki.platform:xwiki-platform-oldcore: >= 12.0.0, < 12.2.1 → fixed in 12.2.1

Description

Impact Any user with SCRIPT right (EDIT right before XWiki 7.4) can gain access to the application server Servlet context which contains tools allowing to instantiate arbitrary Java objects and invoke methods that may lead to arbitrary code execution. Patches It has been patched in both version XWiki 12.2.1 and XWiki 11.10.5. Workarounds The only workaround is to give SCRIPT right only to trusted users. References https://jira.xwiki.org/browse/XWIKI-17141 https://jira.xwiki.org/browse/XWIKI-17266 It's been reported by the GitHub Security Lab under #GHSL-2020-046. For more information If you have any questions or comments about this advisory: • Open an issue in Jira XWiki • Email us at our security mailing list

Related

Alias · CVE (1)

  • CVE-2020-15171 In XWiki before versions 11.10.5 or 12.2.1, any user with SCRIPT right (EDIT right before XWiki 7.4) can gain access to the application… vulnerability

Weakness · CWE (2)

  • CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness
  • CWE-94 Improper Control of Generation of Code weakness

References