GitHub Advisoryadvisory · Maven
GHSA-7r4h-2h23-6jq9 Incorrect Authorization in Jenkins
MEDIUM
Official page ↗
- Aliases
- CVE-2017-2599
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2022-07-01
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: < 2.32.2 → fixed in 2.32.2
• Maven org.jenkins-ci.main:jenkins-core: >= 2.34, < 2.44 → fixed in 2.44
Description
Jenkins before versions 2.44 and 2.32.2 is vulnerable to an insufficient permission check. This allows users with permissions to create new items (e.g. jobs) to overwrite existing items they don't have access to (SECURITY-321).
Related
Alias · CVE (1)
- CVE-2017-2599 Jenkins before versions 2.44 and 2.32.2 is vulnerable to an insufficient permission check. vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness