GitHub Advisoryadvisory · Packagist
GHSA-7rf8-9r8f-qf59 phpMyAdmin Cross-site scripting (XSS) vulnerability in SQL parser
MEDIUM
Official page ↗
- Aliases
- CVE-2016-2559
- Ecosystem
- Packagist
- Packages
- phpmyadmin/phpmyadmin
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-04-24
Affected packages
• Packagist phpmyadmin/phpmyadmin: >= 4.5, < 4.5.5.1 → fixed in 4.5.5.1
Description
Cross-site scripting (XSS) vulnerability in the format function in libraries/sql-parser/src/Utils/Error.php in the SQL parser in phpMyAdmin 4.5.x before 4.5.5.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted query.
Related
Alias · CVE (1)
- CVE-2016-2559 Cross-site scripting (XSS) vulnerability in the format function in libraries/sql-parser/src/Utils/Error.php in the SQL parser in phpMyAdmin… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2016-2559 advisory
- https://github.com/phpmyadmin/phpmyadmin/commit/3a6a9a807d99371ee126635e1a505fc1fe0df32c web
- https://github.com/phpmyadmin/composer package
- https://www.phpmyadmin.net/security/PMASA-2016-10 web
- http://lists.fedoraproject.org/pipermail/package-announce/2016-March/178562.html web
- http://lists.fedoraproject.org/pipermail/package-announce/2016-March/178869.html web