GitHub Advisoryadvisory · npm

GHSA-7v28-g2pq-ggg8 Ghost vulnerable to remote code execution in locale setting change

MEDIUM Published 2022-06-17 Modified 2022-08-10 Official page ↗
Ecosystem
npm
Packages
ghost
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:L
Reviewed
2022-06-17

Affected packages

• npm ghost: < 4.48.2 → fixed in 4.48.2 • npm ghost: >= 5.0.0, < 5.2.3 → fixed in 5.2.3

Description

Impact A vulnerability in an upstream library means an authenticated attacker can abuse locale input to execute arbitrary commands from a file that has previously been uploaded using the file upload functionality in the post editor. Patches Fixed in 5.2.3, all 5.x sites should update as soon as possible. Fixed in 4.48.2, all 4.x sites should update as soon as possible. Workarounds Patched versions of Ghost add validation to the locale input to prevent execution of arbitrary files. Updating Ghost is the quickest complete solution. As a workaround, if for any reason you cannot update your Ghost instance, you can block the `POST /ghost/api/admin/settings/` endpoint, which will also disable updating settings for your site. For more information If you have any questions or comments about this advisory: • Email us at [email protected] Credits • devx00 - https://twitter.com/devx00

References