GitHub Advisoryadvisory · Packagist

GHSA-7v68-3pr5-h3cr Drupal Core Insufficient Contextual Links validation leads to Remote Code Execution

CRITICAL Published 2024-05-15 Modified 2024-05-15 Official page ↗
Ecosystem
Packagist
Packages
drupal/core
Severity
Critical
Weaknesses
CWE-94
Reviewed
2024-05-15

Affected packages

• Packagist drupal/core: >= 8.0.0, < 8.5.8 → fixed in 8.5.8 • Packagist drupal/core: >= 8.6.0, < 8.6.2 → fixed in 8.6.2

Description

The Contextual Links module doesn't sufficiently validate the requested contextual links. This vulnerability is mitigated by the fact that an attacker must have a role with the permission "access contextual links".

Related

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References