GitHub Advisoryadvisory · Maven

GHSA-7vpq-g998-qpv7 Netty denial of service vulnerability

MEDIUM Published 2022-05-13 Modified 2024-04-16 Official page ↗
Aliases
CVE-2014-0193
Ecosystem
Maven
Packages
io.netty:netty, io.netty:netty-all
Severity
Moderate
Reviewed
2023-08-07

Affected packages

• Maven io.netty:netty: >= 3.6.0.Beta1, < 3.6.9.Final → fixed in 3.6.9.Final • Maven io.netty:netty: >= 3.7.0.Final, < 3.7.1.Final → fixed in 3.7.1.Final • Maven io.netty:netty: >= 3.8.0.Final, < 3.8.2.Final → fixed in 3.8.2.Final • Maven io.netty:netty: >= 3.9.0.Final, < 3.9.1.Final → fixed in 3.9.1.Final • Maven io.netty:netty: >= 4.0.0.Alpha1, < 4.0.19.Final → fixed in 4.0.19.Final • Maven io.netty:netty-all: >= 4.0.0.Alpha1, < 4.0.19.Final → fixed in 4.0.19.Final

Description

`WebSocket08FrameDecoder` in Netty 3.6.x before 3.6.9, 3.7.x before 3.7.1, 3.8.x before 3.8.2, 3.9.x before 3.9.1, and 4.0.x before 4.0.19 allows remote attackers to cause a denial of service (memory consumption) via a `TextWebSocketFrame` followed by a long stream of `ContinuationWebSocketFrames`.

Related

Alias · CVE (1)

  • CVE-2014-0193 WebSocket08FrameDecoder in Netty 3.6.x before 3.6.9, 3.7.x before 3.7.1, 3.8.x before 3.8.2, 3.9.x before 3.9.1, and 4.0.x before 4.0.19… vulnerability

References