GitHub Advisoryadvisory · Packagist

GHSA-7w53-hfpw-rg3g Symfony Arbitrary PHP code Execution

HIGH Published 2022-05-17 Modified 2025-04-14 Official page ↗
Aliases
CVE-2013-1397
Ecosystem
Packagist
Packages
symfony/symfony, symfony/yaml
Severity
High
Weaknesses
CWE-94
Reviewed
2023-08-28

Affected packages

• Packagist symfony/symfony: >= 2.2.0-BETA1, < 2.2.0-BETA2 → fixed in 2.2.0-BETA2 • Packagist symfony/symfony: >= 2.0.0, < 2.0.22 → fixed in 2.0.22 • Packagist symfony/symfony: >= 2.1.0, < 2.1.7 → fixed in 2.1.7 • Packagist symfony/yaml: >= 2.0.0, < 2.0.22 → fixed in 2.0.22 • Packagist symfony/yaml: >= 2.1.0, < 2.1.7 → fixed in 2.1.7 • Packagist symfony/yaml: >= 2.2.0-BETA1, < 2.2.0-BETA2 → fixed in 2.2.0-BETA2

Description

Symfony 2.0.x before 2.0.22, 2.1.x before 2.1.7, and 2.2.x remote attackers to execute arbitrary PHP code via a serialized PHP object to the (1) Yaml::parse or (2) Yaml\Parser::parse function, a different vulnerability than CVE-2013-1348.

Related

Alias · CVE (1)

  • CVE-2013-1397 Symfony 2.0.x before 2.0.22, 2.1.x before 2.1.7, and 2.2.x remote attackers to execute arbitrary PHP code via a serialized PHP object to… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References