GitHub Advisoryadvisory · Go

GHSA-7wq2-32h4-9hc9 AWS Advanced Go Wrapper: Privilege Escalation in Aurora PostgreSQL Instance

HIGH Published 2025-11-13 Modified 2026-05-06 Official page ↗
Ecosystem
Go
Packages
github.com/aws/aws-advanced-go-wrapper/awssql, github.com/aws/aws-advanced-go-wrapper/auth-helpers, github.com/aws/aws-advanced-go-wrapper/aws-secrets-manager, github.com/aws/aws-advanced-go-wrapper/federated-auth, github.com/aws/aws-advanced-go-wrapper/iam, github.com/aws/aws-advanced-go-wrapper/mysql-driver, github.com/aws/aws-advanced-go-wrapper/okta, github.com/aws/aws-advanced-go-wrapper/otlp, github.com/aws/aws-advanced-go-wrapper/pgx-driver, github.com/aws/aws-advanced-go-wrapper/xray
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-470
Reviewed
2025-11-13

Affected packages

• Go github.com/aws/aws-advanced-go-wrapper/awssql: < 1.1.1 → fixed in 1.1.1 • Go github.com/aws/aws-advanced-go-wrapper/auth-helpers: < 1.0.2 → fixed in 1.0.2 • Go github.com/aws/aws-advanced-go-wrapper/aws-secrets-manager: < 1.0.2 → fixed in 1.0.2 • Go github.com/aws/aws-advanced-go-wrapper/federated-auth: < 1.0.2 → fixed in 1.0.2 • Go github.com/aws/aws-advanced-go-wrapper/iam: < 1.0.2 → fixed in 1.0.2 • Go github.com/aws/aws-advanced-go-wrapper/mysql-driver: < 1.0.2 → fixed in 1.0.2 • Go github.com/aws/aws-advanced-go-wrapper/okta: < 1.0.2 → fixed in 1.0.2 • Go github.com/aws/aws-advanced-go-wrapper/otlp: < 1.0.2 → fixed in 1.0.2 • Go github.com/aws/aws-advanced-go-wrapper/pgx-driver: < 1.0.2 → fixed in 1.0.2 • Go github.com/aws/aws-advanced-go-wrapper/xray: < 1.0.2 → fixed in 1.0.2

Description

Description of Vulnerability: An issue in AWS Wrappers for Amazon Aurora PostgreSQL may allow for privilege escalation to rds_superuser role. A low privilege authenticated user can create a crafted function that could be executed with permissions of other Amazon Relational Database Service (RDS) users. We recommend customers upgrade to the following versions: AWS Go Wrapper to 2025-10-17 Source of Vulnerability Report: Allistair Ishmael Hakim [email protected] Affected products & versions: AWS Go Wrapper < 2025-10-17 Platforms: MacOS/Windows/Linux

Related

Weakness · CWE (1)

  • CWE-470 Use of Externally-Controlled Input to Select Classes or Code weakness

References