GitHub Advisoryadvisory · Packagist

GHSA-7x4w-j98p-854x Cross site scripting vulnerability with discussion titles

CRITICAL Published 2022-11-21 Modified 2022-11-28 Official page ↗
Aliases
CVE-2022-41938
Ecosystem
Packagist
Packages
flarum/core
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
Weaknesses
CWE-79
Reviewed
2022-11-21

Affected packages

• Packagist flarum/core: >= 1.5.0, < 1.6.2 → fixed in 1.6.2

Description

Flarum's page title system allowed for page titles to be converted into HTML DOM nodes when pages were rendered. The change was made after `v1.5` and was not noticed. This allowed an attacker to inject malicious HTML markup using a discussion title input, either by creating a new discussion or renaming one. The XSS attack occurs after a visitor opens the relevant discussion page. Impact All communities running Flarum from `v1.5.0` to `v1.6.1` are impacted. Patches The vulnerability has been fixed and published as flarum/core `v1.6.2`. All communities running Flarum from `v1.5.0` to `v1.6.1` have to upgrade as soon as possible to v1.6.2 using: ``` composer update --prefer-dist --no-dev -a -W ``` You can then confirm you run the latest version using: ``` composer show flarum/core ``` Workarounds None For more information For any questions or comments on this vulnerability please visit https://discuss.flarum.org/d/27558. For support questions create a discussion at https://discuss.flarum.org/t/support. A reminder that if you ever become aware of a security issue in Flarum, please report it to us privately by emailing [email protected], and we will address it promptly.

Related

Alias · CVE (1)

  • CVE-2022-41938 Flarum is an open source discussion platform. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References