GitHub Advisoryadvisory · Packagist

GHSA-7x6f-jvmg-6fgp TYPO3 Direct Mail Extension Vulnerable to Cross-Site Scripting (XSS)

LOW Published 2022-05-02 Modified 2025-04-10 Official page ↗
Aliases
CVE-2009-4159
Ecosystem
Packagist
Packages
directmailteam/direct-mail
Severity
Low
CVSS vector
CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
Weaknesses
CWE-79
Reviewed
2025-04-10

Affected packages

• Packagist directmailteam/direct-mail: < 2.6.5 → fixed in 2.6.5

Description

Cross-site scripting (XSS) vulnerability in the newsletter configuration feature in the backend module in the Direct Mail (direct_mail) extension 2.6.4 and earlier for TYPO3 allows remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.

Related

Alias · CVE (1)

  • CVE-2009-4159 Cross-site scripting (XSS) vulnerability in the newsletter configuration feature in the backend module in the Direct Mail (direct_mail)… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References