GitHub Advisoryadvisory · npm

GHSA-7xfq-xh6v-4mrm Malicious Package in json-serializer

CRITICAL Published 2020-09-01 Modified 2021-10-01 Official page ↗
Ecosystem
npm
Packages
json-serializer
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-506
Reviewed
2020-08-31

Affected packages

• npm json-serializer: >= 2.0.10, < 2.0.11 → fixed in 2.0.11

Description

Version 2.0.10 of `json-serializer` contained malicious code. The code when executed in the browser would enumerate password, cvc, cardnumber fields from forms and send the extracted values to `https://js-metrics.com/minjs.php?pl=` Recommendation If version 2.0.10 of this module is found installed you will want to replace it with a version before or after 2.0.10. In addition to replacing the installed module, you will also want to evaluate your application to determine whether or not user data was compromised.

Related

Weakness · CWE (1)

  • CWE-506 Embedded Malicious Code weakness

References