GitHub Advisoryadvisory · Maven
GHSA-7xr3-rgwh-pw22 Denial of service vulnerability exists when .NET and .NET Core improperly process XML documents
HIGH
Official page ↗
- Aliases
- CVE-2018-8030
- Ecosystem
- Maven
- Packages
- org.apache.qpid:apache-qpid-broker-j
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2020-06-16
Affected packages
• Maven org.apache.qpid:apache-qpid-broker-j: >= 7.0.0, < 7.1.0 → fixed in 7.1.0
Description
A Denial of Service vulnerability was found in Apache Qpid Broker-J versions 7.x before 7.1.0 when AMQP protocols 0-8, 0-9 or 0-91 are used to publish messages with size greater than allowed maximum message size limit (100MB by default). The broker crashes due to the defect. AMQP protocols 0-10 and 1.0 are not affected.
Related
Alias · CVE (1)
- CVE-2018-8030 A Denial of Service vulnerability was found in Apache Qpid Broker-J versions 7.0.0-7.0.4 when AMQP protocols 0-8, 0-9 or 0-91 are used to… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-8030 advisory
- https://github.com/apache/qpid-broker-j/commit/025b48f3193e2b10b1c41d2bc3bcfc9cfc238a27 web
- https://github.com/advisories/GHSA-7xr3-rgwh-pw22 advisory
- https://github.com/apache/qpid-broker-j web
- https://issues.apache.org/jira/browse/QPID-8203 web
- https://lists.apache.org/thread.html/1089a4f351a1bdca0618199e53bceeec59a10bf4e3008018d6949876@%3Cusers.qpid.apache.org%3E web
- http://www.securitytracker.com/id/1041138 web