GitHub Advisoryadvisory · PyPI

GHSA-82fw-ch24-j34w Lollms has an Improper Access Control vulnerability

HIGH Published 2026-02-02 Modified 2026-02-02 Official page ↗
Aliases
CVE-2026-1117
Ecosystem
PyPI
Packages
lollms
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
Weaknesses
CWE-284
Reviewed
2026-02-02

Affected packages

• PyPI lollms: < 2.1.0 → fixed in 2.1.0

Description

A vulnerability in the `lollms_generation_events.py` component of parisneo/lollms version 5.9.0 allows unauthenticated access to sensitive Socket.IO events. The `add_events` function registers event handlers such as `generate_text`, `cancel_generation`, `generate_msg`, and `generate_msg_from` without implementing authentication or authorization checks. This allows unauthenticated clients to execute resource-intensive or state-altering operations, leading to potential denial of service, state corruption, and race conditions. Additionally, the use of global flags (`lollmsElfServer.busy`, `lollmsElfServer.cancel_gen`) for state management in a multi-client environment introduces further vulnerabilities, enabling one client's actions to affect the server's state and other clients' operations. The lack of proper access control and reliance on insecure global state management significantly impacts the availability and integrity of the service.

Related

Alias · CVE (1)

  • CVE-2026-1117 A vulnerability in the `lollms_generation_events.py` component of parisneo/lollms version 5.9.0 allows unauthenticated access to sensitive… vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References