GitHub Advisoryadvisory · Packagist
GHSA-82p4-55gj-956p Magento Improper Access Control vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2025-24435
- Ecosystem
- Packagist
- Packages
- magento/community-edition, magento/project-community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-284
- Reviewed
- 2025-02-28
Affected packages
• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-p4 → fixed in 2.4.7-p4
• Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p9 → fixed in 2.4.6-p9
• Packagist magento/community-edition: < 2.4.4-p12 → fixed in 2.4.4-p12
• Packagist magento/community-edition: 2.4.7 (no fix yet)
• Packagist magento/community-edition: 2.4.6 (no fix yet)
• Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p11 → fixed in 2.4.5-p11
• Packagist magento/community-edition: 2.4.5 (no fix yet)
• Packagist magento/community-edition: 2.4.4 (no fix yet)
• Packagist magento/community-edition: 2.4.8-beta1 (no fix yet)
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
Description
Adobe Commerce versions 2.4.7-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by an Improper Access Control vulnerability that could result in Privilege escalation. A low-privileged attacker could leverage this vulnerability to bypass security measures and gain unauthorized access to modify limited fields. Exploitation of this issue does not require user interaction.
Related
Alias · CVE (1)
- CVE-2025-24435 Adobe Commerce versions 2.4.8-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by an Improper Access Control… vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness