GitHub Advisoryadvisory · Packagist
GHSA-83jv-4prm-34g7 Shopware Remote Code Execution Vulnerability
CRITICAL
Official page ↗
- Ecosystem
- Packagist
- Packages
- shopware/shopware
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-1336
- Reviewed
- 2024-05-21
Affected packages
• Packagist shopware/shopware: >= 4.2.0, < 5.2.25 → fixed in 5.2.25
Description
Under certain circumstances it is possible to execute an authorized foreign code in Shopware version prior to 5.2.25.
Related
Weakness · CWE (1)
- CWE-1336 Improper Neutralization of Special Elements Used in a Template Engine weakness
References
- https://github.com/shopware5/shopware/commit/8f6a7cefcba7547276892b82f64e4874c1a0dfed web
- https://community.shopware.com/_detail_2015.html web
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-06-2017?category=shopware-5-en/security-updates web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/shopware/shopware/2017-06-22.yaml web
- https://github.com/shopware5/shopware package