GitHub Advisoryadvisory · Maven

GHSA-83q5-whqp-r8jr Apache Pulsar WebSocket Proxy contains an Improper Authentication vulnerability

HIGH Published 2023-12-20 Modified 2023-12-20 Official page ↗
Aliases
CVE-2023-37544
Ecosystem
Maven
Packages
org.apache.pulsar:pulsar-websocket
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-287
Reviewed
2023-12-20

Affected packages

• Maven org.apache.pulsar:pulsar-websocket: < 2.10.5 → fixed in 2.10.5 • Maven org.apache.pulsar:pulsar-websocket: >= 2.11.0, < 2.11.2 → fixed in 2.11.2 • Maven org.apache.pulsar:pulsar-websocket: >= 3.0.0, < 3.0.1 → fixed in 3.0.1

Description

Improper Authentication vulnerability in Apache Pulsar WebSocket Proxy allows an attacker to connect to the /pingpong endpoint without authentication. This issue affects Apache Pulsar WebSocket Proxy: from 2.8.0 through 2.8.*, from 2.9.0 through 2.9.*, from 2.10.0 through 2.10.4, from 2.11.0 through 2.11.1, 3.0.0. The known risks include a denial of service due to the WebSocket Proxy accepting any connections, and excessive data transfer due to misuse of the WebSocket ping/pong feature. 2.10 Pulsar WebSocket Proxy users should upgrade to at least 2.10.5. 2.11 Pulsar WebSocket Proxy users should upgrade to at least 2.11.2. 3.0 Pulsar WebSocket Proxy users should upgrade to at least 3.0.1. 3.1 Pulsar WebSocket Proxy users are unaffected. Any users running the Pulsar WebSocket Proxy for 2.8, 2.9, and earlier should upgrade to one of the above patched versions.

Related

Alias · CVE (1)

  • CVE-2023-37544 Improper Authentication vulnerability in Apache Pulsar WebSocket Proxy allows an attacker to connect to the /pingpong endpoint without… vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References