GitHub Advisoryadvisory · Maven

GHSA-83r3-c79w-f6wc High severity vulnerability that affects org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service

HIGH Published 2018-11-21 Modified 2021-09-03 Official page ↗
Aliases
CVE-2015-7521
Ecosystem
Maven
Packages
org.apache.hive:hive, org.apache.hive:hive-exec, org.apache.hive:hive-service
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L
Weaknesses
CWE-287
Reviewed
2020-06-16

Affected packages

• Maven org.apache.hive:hive: >= 1.0.0, < 1.2.2 → fixed in 1.2.2 • Maven org.apache.hive:hive-exec: >= 1.0.0, < 1.2.2 → fixed in 1.2.2 • Maven org.apache.hive:hive-service: >= 1.0.0, < 1.2.2 → fixed in 1.2.2

Description

The authorization framework in Apache Hive 1.0.0, 1.0.1, 1.1.0, 1.1.1, 1.2.0 and 1.2.1, on clusters protected by Ranger and SqlStdHiveAuthorization, allows attackers to bypass intended parent table access restrictions via unspecified partition-level operations.

Related

Alias · CVE (1)

  • CVE-2015-7521 The authorization framework in Apache Hive 1.0.0, 1.0.1, 1.1.0, 1.1.1, 1.2.0 and 1.2.1, on clusters protected by Ranger and… vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References