GitHub Advisoryadvisory · npm

GHSA-83rp-q473-j88c Ghost: Path Traversal Vulnerability in Ghost ImageSize Service

LOW Published 2026-10-07 Modified 2026-10-07 Official page ↗
Aliases
CVE-2026-105683
Ecosystem
npm
Packages
ghost
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:L
Weaknesses
CWE-35
Reviewed
2026-10-07

Affected packages

• npm ghost: >= 6.14.0, < 6.27.0 → fixed in 6.27.0

Description

Impact An input validation issue may have allowed staff users to access local files outside the intended data storage directories on the server. Vulnerable versions This vulnerability is present in Ghost from v6.14.0 up to v6.27.0. Patches v6.27.0 contains a fix for this issue. How to update For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here. If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here. References Ghost thanks l3tchupkt and [email protected] for disclosing this vulnerability responsibly. For more information If you have any questions or comments about this advisory, email us at [email protected].

Related

Alias · CVE (1)

  • CVE-2026-105683 Ghost is a Node.js content management system. vulnerability

Weakness · CWE (1)

  • CWE-35 Path Traversal: '.../...//' weakness

References