GitHub Advisoryadvisory · Packagist

GHSA-83wp-f5c3-hqqr Laravel framework susceptible to reflected cross-site scripting

MEDIUM Published 2025-03-10 Modified 2025-03-14 Official page ↗
Aliases
CVE-2024-13919
Ecosystem
Packagist
Packages
laravel/framework
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2025-03-10

Affected packages

• Packagist laravel/framework: >= 11.9.0, < 11.36.0 → fixed in 11.36.0

Description

The Laravel framework versions between 11.9.0 and 11.35.1 are susceptible to reflected cross-site scripting due to an improper encoding of route parameters in the debug-mode error page.

Related

Alias · CVE (1)

  • CVE-2024-13919 The Laravel framework versions between 11.9.0 and 11.35.1 are susceptible to reflected cross-site scripting due to an improper encoding of… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References